Обновлен Translator RU до v.1.6

  1. Добавлена возможность отключения контекстного меню.*
    Как для выделенного текста, так и для всей страницы. Кто переводит, к примеру, только клавишами, лишние пункты в меню им без надобности.
  2. Добавлена мультиязычная локализация.
    Специально для тех, кто предпочитает ПО только на английском 😉
  3. Добавлена возможность открытия окна настроек кликом по направлению перевода в пузыре:
  4. Исправлено: не отображалась подсказка "Слишком длинный текст!" при превышении количества выделенных символов перевода.
  5. Исправлено: ломался встроенный стиль текста в пузыре при переводе одного слова на некоторых сайтах.

*После обновления зайдите в настройки расширения и отметьте галками пункты с контекстным меню (если желаете продолжать ими пользоваться).

Обновить >>>

Комментарии (9) к “Обновлен Translator RU до v.1.6

  1. Перезалил файл, версия та же - 1.6.
    Подправил цвет направления перевода - будет такой же, как у основного текста перевода. Не учел, что пользователь может использовать тёмную тему и на темном фоне направление перевода было бы не видно.

  2. На данном этапе все работает Opera 41. Единственное нет ли возможности сделать сохранение настроек в автоматическом режиме, а то 20 минут не мог понять почему не появляется в контекстном меню =) оказывается лопухнулся сохранить не нажал =)

    З.Ы и ещё одно не планируете ли вы выложить данное расширение в официальный магазин гугл с автообновлением, чтобы без проблем можно было пользоваться в браузере гугл хром (без вашего расширения браузер не браузер=)) да и для Opera подойдет, и если нет то почему?

    • 1. Оно и так в автоматическом режиме, если устанавливать с нуля. При обновлении с версии на версию - это разовое неудобство, поэтому и выделено красным.
      2. В магазин гугла - нет. Они за это денег хотят, плюс, данные твоей карты, а может и еще чего... Как-то не готов делиться ни тем, ни другим. Пойду на эти деньги лучше мышку новую куплю 🙂 Про оперный - не знаю какие там условия. В Оперу же без проблем можно было устанавливать сторонние расширения или уже зарезали?
      А, автообновление - зло!

      • С Opera проблем нет расширения без проблем ставятся и работают, а вот с гуглом прям беда, отключает и все тут

        • В шапке сайта давно уже надо было написать "Расширения не для Google Chrome".
          Ничего не поделаешь... такова политика "корпорации добра".
          Можете сами поместить в гуглозин. Я не против.

  3. Не могли бы вы добавить возможность выбрать язык с которого переводится текст в контекстное меню? Иногда он определяется неверно если в тексте находятся слова из другого языка. Например, когда между английских слов есть одно русское слово идет перевод с русского на русский.

    • Автоопределение языка исходного текста происходит на стороне гугла, расширение в этом не участвует. Ручное определение не планируется - уж больно редко ошибается, и захламлять, особенно контекстное, не хочется.

  4. Добавьте информацию о том как установить ваше расширение в Хром. Для этого всего-то нужно открыть .crx как архив, затем взять содержимое этого архива и положить в какую-нибудь папку (например создать папку и назвать её Translator_RU_1.6), после этого перейти во вкладку chrome://extensions/, включить Режим разработка, он находится в самом верху и перетащить вашу папку в эту вкладку (методом drag and drop). После этого расширение перестанет выключатся при каждом заходе в Хром.

    • Расширения, выложенные на этом сайте не для Google Chrome, о чем и говорит предупреждение на странице загрузок. Если пользователь использует сторонние расширения в этом браузере, то должен быть в курсе козней гугла и как их обойти.
      Я не пользуюсь Google Chrome, тестировать способы установки, которые возможно к следующей версии отвалятся, не могу и не хочу. Полно хромов "с человеческим лицом", без заскоков.

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *